Cobweb Solutions Ltd - Microsoft orders stuck in submitted – Incident details

All systems operational

Microsoft orders stuck in submitted

Resolved
Major outage
Started about 1 month agoLasted 1 day

Affected

Cloud Market

Major outage from 9:33 AM to 10:53 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Investigating
    UTC
    Investigating

    We’re aware of an issue affecting some Microsoft orders, where they may appear as submitted or pending.

    We’re monitoring this and will share an update as soon as we have more information.